We are currently having sound quality issues with our telephony system in the EU
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the inconvenience.
Posted Feb 22, 2021 - 13:05 CET
Investigating
Due to technical issues with our telephony system it might be difficult to reach our consumer or merchant service by phone. We are working on solving this issue as soon as possible and apologize for any inconvenience caused in the meantime. We kindly request that you contact us through the chat instead.
Posted Feb 22, 2021 - 11:14 CET
This incident affected: Customer Service.