Merchant Portal/Klarna Online login unavailable
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 17 days ago. Jul 04, 2019 - 16:47 CEST
Identified
The system that handles logins for the Merchant Portal and Klarna Online is currently unavailable. We are working on a solution and apologise for any inconvenience caused.
Posted 17 days ago. Jul 04, 2019 - 16:33 CEST
This incident affected: Klarna Online and Merchant Portal.