Merchant Operations degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 16:09 CET

Investigating

We are currently experiencing issues with Merchant operations in EU and US regions. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 24, 2025 - 15:33 CET
This incident affected: Merchant Operations (Europe, North America).