N26 - unexpected maintenance
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 15:41 CET
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 20:41 CET
Investigating
Due to ongoing maintenance we have deactivated N26 payments for all countries. We apologize for the inconvenience.
Posted Nov 09, 2020 - 20:24 CET
This incident affected: Klarna App.