EU merchant portal connection unstable
Incident Report for Klarna
Resolved
Our engineers have resolved this problem and normal service is resumed. We thank you for your patience and apologize for the inconvenience caused. If you encounter any further trouble in relation to Merchant Portal, please reach out to your technical account manager for further assistance.
Posted May 18, 2020 - 13:06 CEST
Investigating
Merchants in EU are currently experiencing difficulties logging in to Merchant Portal. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted May 18, 2020 - 11:45 CEST
This incident affected: Merchant Portal.