Customer support service/system degradation
Incident Report for Klarna
Resolved
The issues have been resolved. Thank you for your patience.
Posted Feb 14, 2024 - 11:52 CET
Investigating
We are currently experiencing issues with reaching support via phone in the DE region. Please use chat as an alternative to reach us for support. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Feb 14, 2024 - 10:05 CET
This incident affected: Support (Europe).