Klarna App degradation

Incident Report for Klarna

Resolved

The issue was identified on the BankID side, and their team has now implemented a fix.
All services are back to normal.

Thank you for your patience while this was being resolved!
Posted Apr 15, 2025 - 15:01 CEST

Investigating

We are currently experiencing issues with the Klarna App. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 15, 2025 - 14:23 CEST
This incident affected: Klarna App (Europe).