Merchant Operations degradation in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 10, 2023 - 12:06 CET
Investigating
We are currently experiencing issues with the balance report in the Settlements App in Merchant Portal. We are investigating the issue.
Posted Jan 10, 2023 - 09:49 CET
This incident affected: Merchant Operations (Europe).