Users in Spain, Portugal and France may be unable to login or authenticate due to general power outage in Europe

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 15:29 CEST

Investigating

Users in Spain, Portugal and France may be unable to login or authenticate due to general power outage in Europe
Posted Apr 28, 2025 - 14:09 CEST
This incident affected: Klarna App (Europe).