Delayed GBP payouts for merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 11:09 CET
Identified
Merchants who receive payouts in British pound sterling will experience a one day delay to their payouts. This is due to a 3rd party vender issue. We apologize for the delay and thank you for your patience.
Posted Jan 29, 2021 - 16:46 CET