Some EU consumers are unable to pay by card with Klarna Checkout and Klarna Payments
Incident Report for Klarna
Resolved
Following a period of monitoring, we have verified that successful card payment rates have returned to expected levels and that the services provided by our payment processing partners have fully recovered. We apologize for any inconvenience caused by this incident.
Posted Sep 01, 2020 - 21:25 CEST
Investigating
Beginning at 20:53 (CEST), we have observed a higher than expected failure rate for card payments in the EU. This affects consumers' ability to make card payments through Klarna Checkout and Klarna Payments. We are working with our upstream payment processing partners to resolve this problem as soon as possible.
Posted Sep 01, 2020 - 21:09 CEST
This incident affected: Klarna Checkout (KCO), Klarna Payments (KP), and Card Payments.