Merchant Portal degradation (settlement information)
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 16:50 CEST
Investigating
We are currently experiencing a degradation of Merchant Portal in the EU, resulting in delays in settlement information. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 21, 2022 - 14:13 CEST
This incident affected: Merchant Operations (Europe).