Merchant Portal degradation for mails to Office365

Incident Report for Klarna

Resolved

Office365 has resolved the issue and we can confirm emails are being delivered again.
Posted Nov 10, 2023 - 08:52 CET

Update

Office365 has confirmed that the issue is on their side and that they are working on a solution. Thank you for your patience.
Posted Nov 09, 2023 - 16:27 CET

Update

We are still working closely with office 365 and continue to investigate the issue. Thank you for your patience.
Posted Nov 09, 2023 - 08:19 CET

Identified

We have identified the issue to be with merchants using Office365 mail, hence not connected to specific regions. We are in contact with Office365 to further investigate the issue. Thank you for your patience.
Posted Nov 07, 2023 - 12:11 CET

Investigating

We are currently experiencing issues with emails (codes for login) for Merchant Portal in Finland and Norway. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 07, 2023 - 10:11 CET
This incident affected: Merchant Operations (Europe).