Klarna Card degradation in Germany
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Dec 08, 2023 - 07:46 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 08, 2023 - 06:39 CET
Investigating
We are currently experiencing a degradation of Klarna Card in Germany since 04:00. Consumers might be unable to use their Klarna card. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Dec 08, 2023 - 05:30 CET
This incident affected: Klarna Card (Europe).