BankId in Finland has a degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Sep 06, 2022 - 19:46 CEST

Investigating

We are currently experiencing a degradation of BankId in Finland. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 06, 2022 - 19:16 CEST
This incident affected: Purchase API (Europe).