Issues with 3DS authentication affecting Klarna Card purchases in Europe.

Incident Report for Klarna

Resolved

The issues has been resolved.
Posted Jun 06, 2025 - 04:06 CEST

Investigating

Klarna Card for online purchases are degraded due to an issue with 3DS authentication. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jun 06, 2025 - 03:01 CEST
This incident affected: Klarna Card (Europe).