Klarna Bank Account and Klarna Debit Card degradation in Sweden and Germany

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Nov 20, 2023 - 15:58 CET

Investigating

We are currently experiencing issues with the Klarna Bank Account and Klarna Debit Card in Sweden and Germany. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 20, 2023 - 15:24 CET
This incident affected: Klarna Bank Account (Europe).