Merchant Portal degradation in the US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 16:32 CEST
Identified
We are currently experiencing issues with Settlements App in the US. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 19, 2022 - 14:37 CEST
This incident affected: Merchant Operations (North America).