We are currently seeing issues with receiving shipping address information from around 40 merchants in the EU region
Incident Report for Klarna
Resolved
This incident has been resolved by our third-party provider at 12:51 CEST.
Posted Apr 13, 2021 - 13:01 CEST
Investigating
Our engineering teams are currently investigating the issue with our third-party provider.
Posted Apr 13, 2021 - 12:29 CEST
This incident affected: Klarna Payments (KP).