Direct Debit payments failing in US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 20:17 CEST
Update
We are continuing to investigate this issue.
Posted Sep 09, 2022 - 20:16 CEST
Investigating
Customers in the US are currently experiencing difficulties with Direct Debit (ACH) payments. Our engineers are investigating the issue and we apologies for the inconvenience caused. We will provide further updates as soon as possible.
Posted Sep 09, 2022 - 17:38 CEST