Service Disruption Payments
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 08, 2021 - 17:28 CEST
Investigating
We are currently having issues that may affect payments. We are working to resolve this as soon as possible. We apologize for the inconvenience.
Posted Apr 08, 2021 - 16:53 CEST
This incident affected: Klarna Checkout (KCO) and Klarna Payments (KP).