Risk of delays in payouts in the EU
Incident Report for Klarna
Resolved
The transactions have been processed now and the incident is resolved. We apologize for the inconvenience.
Posted May 24, 2021 - 13:06 CEST
Investigating
Consumer withdrawals in Germany and merchant settlements in the EU are at risk of a delay. Technical teams are investigating.
Posted May 24, 2021 - 12:49 CEST