Klarna Payments degradation

Incident Report for Klarna

Resolved

Issue has been resolved.
Posted Mar 22, 2026 - 13:21 CET

Investigating

We are currently observing abnormal conversion rate behaviour for token charges in United States on the Klarna Network. The matter is under investigation, and teams are working to restore normal performance.
Posted Mar 22, 2026 - 12:03 CET
This incident affected: Klarna Payments (North America).