For Klarna Payments in the US, ~5% of customers can't login or sign-up to user account.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 15, 2021 - 14:34 CEST
Investigating
We are currently investigating this issue.
Posted Jul 15, 2021 - 14:33 CEST
This incident affected: Klarna Payments (KP).