Klarna Payments degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 19:19 CET

Investigating

A service degradation has been identified affecting Klarna's in-store payment service. Klarna is actively investigating the issue and implementing mitigation measures. Service functionality may be impacted during this time. Further updates will be communicated as information becomes available.
Posted Mar 11, 2026 - 17:18 CET
This incident affected: Klarna Payments (North America).