Merchant Portal is currently having unexpected downtime
Incident Report for Klarna
Resolved
This has been resolved since 15:23
Posted 3 months ago. May 22, 2019 - 16:39 CEST
Investigating
We are experiencing hiccups on the Merchant Portal where some users might not be able to log in or in general slower loading times. More information to follow once we have investigated the issue.
Posted 3 months ago. May 22, 2019 - 15:13 CEST
This incident affected: Merchant Portal.