Merchant onboarding system degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 10:02 CEST
Investigating
We are currently experiencing issues with the merchant onboarding process for multiple regions in Europe. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 06, 2023 - 08:38 CEST
This incident affected: Merchant Onboarding (Europe).