EU customers unable to see orders made after 21:36 CET
Incident Report for Klarna
Resolved
Our engineers have resolved the problem and customers are now able to see their new orders. We thank you for your patience and apologize for the inconvenience caused. If you encounter any further issues viewing your recent orders, please reach out to us for help using the Klarna app.
Posted Mar 18, 2020 - 00:51 CET
Identified
Our engineers have identified the cause of the issue and continue working towards resolving the problem. We thank you for your patience and apologize for the inconvenience caused.
Posted Mar 17, 2020 - 23:52 CET
Investigating
Customers in the EU using the Klarna App are currently unable to see orders they have placed after 21:36 CET today. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Mar 17, 2020 - 22:37 CET
This incident affected: Klarna App.