Settlements reports currently unavailable for EU merchants
Incident Report for Klarna
Resolved
We have verified that EU merchants are now able to download settlement reports from the Merchant Portal.
Posted Sep 22, 2020 - 10:23 CEST
Identified
Merchants based in the EU are currently unable to download their settlement reports from the Merchant Portal. We have identified the cause of this problem are we are working to resolve it as soon as possible. We apologize for any inconvenience caused during this time.
Posted Sep 22, 2020 - 10:08 CEST
This incident affected: Merchant Portal.