Klarna App degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 16:07 CEST
Investigating
We had an issue with a subset of payments in Klarna App between 14.47 and 15.59 CET. The service is not fully restored. Thank you for your patience
Posted Sep 22, 2022 - 16:07 CEST
This incident affected: Klarna App (Europe).