New merchants are currently unable to complete the On-Boarding
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the delay and thank you for your patience.
Posted Mar 18, 2021 - 16:42 CET
Investigating
Some merchants based in the EU might experience issues using recently updated products. This is due to an identified technical problem which is currently being remediated. We apologize for the delay and thank you for your patience.
Posted Mar 18, 2021 - 14:30 CET