Issue with BillPay Backoffice
Incident Report for Klarna
Resolved
The issue is resolved. We are back to normal operation.
Posted 3 months ago. Jun 30, 2019 - 06:25 CEST
Identified
We are experiencing issue with our backoffice, website and several services are affected. Our engineering team is working on the issue. We are sorry about the inconvenience.
Posted 3 months ago. Jun 30, 2019 - 03:06 CEST
This incident affected: BillPay.