Merchants are currently unable to change their bank account details through Klarna Merchant Portal
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 10:33 CET
Investigating
Merchants are currently unable to change their bank account details through Klarna Merchant Portal. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Feb 14, 2024 - 16:50 CET
This incident affected: Merchant Operations (Europe, North America).