1% to 3% more EU consumers than expected are declined credit
Incident Report for Klarna
Resolved
We have determined that this problem impacted credit assessments between 15:20 - 16:30 (CEST). Following a period of monitoring, we have verified that successful credit assessments and order conversions have now returned to expected rates.
Posted Sep 01, 2020 - 18:09 CEST
Investigating
Since approximately 15:20 (CEST) today (September 1), our credit assessments of consumers in the EU have resulted in a 1% to 3% higher number of consumers being declined credit than we would ordinarily expect. This may be reflected in a lower conversion rate for merchants with an EU consumer base. We are currently investigating and will provide further updates in due course.
Posted Sep 01, 2020 - 17:33 CEST
This incident affected: Klarna Checkout (KCO).