US Merchants are unable to download PDF summary for multiple settlements.
Incident Report for Klarna
Resolved
The issue has now been resolved.
Posted Sep 10, 2020 - 14:28 CEST
Update
We are continuing to investigate this issue.
Posted Sep 10, 2020 - 14:27 CEST
Investigating
Merchants in the US are currently unable to download a PDF summary for multiple settlements.

Alternatively, a CSV version of the summary is available as well as PDF reports for single settlements.

Our team is investigating the issue.
Posted Sep 10, 2020 - 12:09 CEST
This incident affected: Merchant Portal.