Financing UK (Term Loan) are showing degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 18:41 CET
Investigating
We are experiencing a degradation of Financing (Term Loan) since November 9th 10:00 CET in UK. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 13, 2023 - 12:07 CET
This incident affected: Purchase API (Europe).