Klarna App currently down

Incident Report for Klarna

Resolved

A fix has been rolled out to the Klarna App and is now working as supposed.
Posted May 25, 2018 - 11:14 CEST

Investigating

We are currently experiencing issues with the Klarna App which causes consumers to not be able to log in to the app.
Posted May 25, 2018 - 10:41 CEST