Merchant Operations degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 11:05 CET

Investigating

We are currently experiencing issues with Partners retrieving settlements via SFTP in all regions. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Feb 13, 2025 - 15:36 CET
This incident affected: Merchant Operations (Europe, North America, Asia Pacific).