Onboarding and merchant product changes are delayed in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 02, 2021 - 14:16 CEST
Update
We are continuing to investigate this issue.
Posted Sep 02, 2021 - 10:25 CEST
Investigating
Our automated onboarding API for new merchants has significant delays at the moment. We are currently investigating this issue.
Posted Sep 02, 2021 - 06:53 CEST