Consumers in Austria, Denmark, and Sweden may not be able to pay or Slice/snooze their orders in the Klarna App
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 08:16 CEST
Investigating
Consumers in the Austria, Denmark, and Sweden may be unable to pay, postpone their due dates or change the invoice payment method to Slice in the Klarna App.
Posted Jul 30, 2021 - 07:54 CEST