There may be a 2 day delay of EUR-payouts for Finland merchants & consumers
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the inconvenience.
Posted Mar 10, 2021 - 12:27 CET
Monitoring
Nordea has solved their issues and we are currently verifying to make sure it works as expected.
Posted Mar 10, 2021 - 09:51 CET
Update
Nordea is still having issues. Though we can confirm some merchants received payments today. Some merchants payouts will be delayed for another day (2 days in total). We apologize for the inconvenience.
Posted Mar 09, 2021 - 16:41 CET
Update
Nordea is still having issues. If the issues are not mitigated before 15 CET today, affected payouts will be delayed for another day (2 days in total)
Posted Mar 09, 2021 - 09:52 CET
Identified
Due to a 3rd party vendor, Nordea, Consumers and merchants may see a 1 day delay in payments in Finland. We apologize for the inconvenience.
Posted Mar 08, 2021 - 17:13 CET
This incident affected: Merchant Payouts.