Klarna Card web sign-up disabled in Sweden & Germany
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 3 months ago. May 20, 2019 - 17:52 CEST
Investigating
Sign-up for the Klarna Card through app.klarna.com is currently disabled in Sweden and Germany while we work through some technical issues. We're sorry for the disruption and we'll keep you posted as soon as we have more information.
Posted 3 months ago. May 20, 2019 - 16:54 CEST
This incident affected: Klarna Card.