Klarna Bank Account degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted May 12, 2023 - 02:43 CEST

Investigating

We are currently experiencing issues with the Klarna Bank Account in Germany. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 12, 2023 - 02:32 CEST
This incident affected: Klarna Bank Account (Europe).