Settlement Delays

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 10:37 CET

Identified

The issue has been identified and teams are working on recovery.
Posted Dec 03, 2025 - 23:39 CET

Investigating

We‘re currently experiencing delays with settlements of a subset of orders. We are working to restore it to normal as soon as possible. Thank you for your patience.
Posted Dec 03, 2025 - 09:08 CET
This incident affected: Merchant Settlements/Payouts (Europe).