Merchant payouts delayed for GBP and EUR
Incident Report for Klarna
Resolved
Pending payouts have now been performed. Merchants who have not yet received the payout should expect to receive it by Monday at the latest.
Posted Apr 03, 2020 - 13:21 CEST
Investigating
Merchants being settled in GBP and EUR may experiencing one day delay on the payouts. Our responsible teams are working on this. We are sorry about the interruption.
Posted Apr 03, 2020 - 12:33 CEST