BillPay website unavailable in Germany, Austria, and Switzerland
Incident Report for Klarna
Resolved
Our engineers have resolved this problem and normal service is resumed. We thank you for your patience and apologize for the inconvenience caused.
Posted Sep 25, 2020 - 17:51 CEST
Investigating
The BillPay websites for Germany, Austria, and Switzerland are currently unavailable and we are working to resolve this as soon as possible.
Posted Sep 25, 2020 - 16:36 CEST
This incident affected: BillPay.