Degradation in performance for Klarna Payments through PayBright in Canada
Incident Report for Klarna
Resolved
The issue has now been resolved on PayBright's side and we have confirmed that the issue has been solved. We apologize for the inconvenience caused.
Posted Nov 28, 2020 - 00:23 CET
Investigating
We are currently seeing order placement recovering but PayBright are still experiencing degraded performance in Canada.
Posted Nov 28, 2020 - 00:01 CET
Identified
PayBright has identified the cause of the issue but the issue still remains. We are working closely with PayBright to restore operations as soon as we can.
Posted Nov 27, 2020 - 21:22 CET
Update
PayBright are actively working on solving the issue on their side and we are continuously monitoring the situation.
Posted Nov 27, 2020 - 18:44 CET
Investigating
At 16:18 CET Nov 27, Klarna payments in Canada through PayBright started experiencing a degradation in performance. We are currently investigating the situation.

The cause of the issue is performance problems at our partner PayBright.
Posted Nov 27, 2020 - 17:14 CET
This incident affected: Klarna Payments (KP).