Payment initiation failing in the Netherlands for iDEAL payments connected to account at ABN AMRO
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 19:56 CET
Investigating
Consumers in the Netherlands can not pay with iDEAL when using an account at ABN AMRO. We apologize for any inconvenience this may cause.
Posted Dec 21, 2020 - 12:29 CET
This incident affected: Klarna Checkout (KCO) and Klarna Payment Methods (KPM).