Klarna App degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 23, 2023 - 04:21 CET
Update
We are continuing to investigate this issue.
Posted Jan 23, 2023 - 04:07 CET
Update
We are continuing to investigate this issue.
Posted Jan 23, 2023 - 02:55 CET
Investigating
We are currently experiencing issues with the Klarna App in Europe. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jan 23, 2023 - 01:53 CET
This incident affected: Klarna App (Europe).