Klarna Bank Account degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 23:05 CET
Update
We are continuing to investigate this issue.
Posted Nov 16, 2023 - 23:05 CET
Investigating
We are currently performing planned service maintenance for Klarna Bank Account . We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 16, 2023 - 22:55 CET
This incident affected: Klarna Bank Account (Europe).